CentOS 5.6’da PHP’yi 5.1.6’dan 5.3.6’ya Güncellemek

Bir arkadaşımın sunucusunda ayarlamalar yapılırken PHP’yi kurdum. Ama CentOS’un deposunda hâlâ 5.1.6’nın olduğunu farkettim. Neyse es geçtim sonra güncellerim dedim. Ama gel gelelim phpMyAdmin 5.1.6’da çalışmadı… Tabii ki iş başa düştü.

Sonra internette dolaşırken sevdiğim saydığım kişilerden olan Samed Abi ( Samed Beyribey ) ‘nin şu yazısını gördüm. Ne yazmış bir bakayım dedim. Derdime derman olacak ilacı yazmış. Bana da gidip eczaneden ilacı almak kalmış resmen.

Yazıda iuscommunity ve webtatic depolarından bahsedilmiş. İkisine de tıkladım. Sonra webtatic i kurmaya karar verdim. Kurulumu şöyle efendim.

rpm -Uvh http://repo.webtatic.com/yum/centos/5/latest.rpm

Böyle repoyu download ediyoruz. Ardından

yum --enablerepo=webtatic install php

diyerek PHP’yi kuruyoruz. Ardından

yum --enablerepo=webtatic update php

diyerekte PHP’yi update ediyoruz.

Şu an PHP güncellendi ama sitede şeklinde <?php info(); ?> PHP infosu alıyorsanız ve hâlâ versiyon değişmemişse -ki değişmemesi lazım-

service httpd restart

diyerek Apache’yi yeniden başlatarak PHP’yi güncellemiş oluyoruz.

Not: Eğer nginx kullanıyorsanız aşağıdaki komut verin.

service nginx restart

Samed Beyribey’e bu yazısından dolayı tekrar teşekkür ederim.

 
4 Kudos
Don't move
  1. tesekkurler

  2. centos 5.10 da hata veriyor

    rpm -Uvh http://repo.webtatic.com/yum/centos/5/latest.rpm
    Retrieving http://repo.webtatic.com/yum/centos/5/latest.rpm
    error: skipping http://repo.webtatic.com/yum/centos/5/latest.rpm – transfer failed – Unknown or unexpected error

Yorum Yap


Not - Bunları KullanabilirsinizHTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>